Default software versions will change on Flux

By August 21, 2014News

During the August, 2014 Flux Summer Outage, scheduled from 6 p.m. Saturday, Aug. 23 through Friday, Aug. 29, we will be changing the default versions of a number of software packages. This is being done both to provide more up-to-date, more stable versions, and to provide additional capabilities. The previous default versions will still be available, so if you want or need to continue using the older version, you can, but you will need to provide the version number when you load the module. The Intel compilers and OpenMPI modules are loaded by default when you log in. To use the old versions, you will first need to either unload the new version prior to reloading the older version or you will need to swap versions. Examples of both methods are included below the table. For all other software, you would simply add the version to load the previous version, whether you load manually at a prompt or via the privatemodules/default file. See below and our documentation page for modules.

Table of version changes

Sofware name Old version New version

Intel compiler intel-comp/12.1 intel-comp/14.0.2
MKL mkl/10.3.7 mkl/11.1
OpenMPI openmpi/1.6.0/intel/12.1 openmpi/1.6.5/intel/14.0.2
HDF5 hdf5/1.8.9/intel/12.1 hdf5/1.8.13/intel/14.0.2
NetCDF (see note below) netcdf/4.2.0/intel/12.1 netcdf/4.3.2/intel/14.0.2
FFTW fftw/3.3.2/intel/12.1 fftw/3.3.4/intel/14.0.2
METIS metis/5.0.2/intel/12.1 metis/5.1.0/intel/14.0.2
ParMETIS parmetis/4.0.2/intel/12.1 parmetis/4.0.3/intel/14.0.2
R R/2.15.1 R/3.0.3
Abaqus abaqus/6.12 abaqus/6.14-1
Ansys ansys/14.0 ansys/15.0
Ansys CFX cfx/14.0 cfx/15.0
Ansys Fluent fluent/14.0 fluent/15.0
Ansys HFSS hfss/14.0 hfss/15.0
Maple maple/16.0 maple/18.0
Mathematica mathematica/8.0 mathematica/10.0
Matlab matlab/2012a matlab/2013a
Stata stata/12 stata/13

NetCDF note: The version number for the three languages supported by NetCDF have diverged. The module will bear the version number for the C version. The Fortran version is 4.4.0 and the C++ version is 4.2.1.

Using the old Intel compiler and OpenMPI default versions

If you want or need to use the older Intel compiler and OpenMPI, you can do so at any time by unloading the new default versions and loading the old with the version number. To do that interactively, you would

$ module rm openmpi intel-comp $ module load intel-comp/12.1 openmpi/1.6.0/intel/12.1

Or, if you want to use the module swap method,

$ module swap intel-comp intel-comp/12.1 $ module swap openmpi openmpi/1.6.0/intel/12.1

It would be a good idea to

$ module list

after using either method to verify that you have only desired and compatible modules loaded. If you will use the old default versions more often than not and wish to make them your own, personal default version, you can do that by putting these lines at the top of the privatemodules/default file that is in your home directory.

module rm openmpi intel-comp module load intel-comp/12.1 openmpi/1.6.0/intel/12.1

Put those at the top, so that they are executed prior to any other module loading commands that you may have in the default file. Once you have made those changes, you will get the old default versions on subsequent logins.

Listing software versions and loading a particular one

To find which versions of, for example, the Matlab module are available, use

$ module available matlab -------------- /usr/flux/software/rhel6/Modules/modulefiles -------------- matlab/2010b          matlab/2012b          matlab/2014a matlab/2012a(default) matlab/2013a

To load a particular one, you would specify the package-name/version from that output in your module load command. For example,

$ module load matlab/2014a

Please let us know if you have questions about this by writing to flux-support@umich.edu